summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@open-infrastructure.net>2021-12-04 16:46:01 +0000
committerDaniel Baumann <daniel.baumann@open-infrastructure.net>2021-12-08 05:02:58 +0000
commit6021f24bbf526d34fead6120e9d3961358cb68fb (patch)
tree2be7357675b97d3b72ec13c6b64b865067dad704 /debian/rules
parentAdding VERSION.txt. (diff)
downloadroot-shell-main.tar.xz
root-shell-main.zip
Adding debian version 20211204-1.HEADmain
Signed-off-by: Daniel Baumann <daniel.baumann@open-infrastructure.net>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..7b40d5c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+PACKAGE := open-infrastructure-root-shell
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh ${@}
+
+execute_after_dh_auto_install:
+ rm -f debian/$(PACKAGE)/usr/share/doc/*/CHANGELOG.txt
+ rm -f debian/$(PACKAGE)/usr/share/doc/*/LICENSE.txt
+
+ mv debian/$(PACKAGE)/usr/share/doc/* debian/$(PACKAGE)/usr/share/doc/$(PACKAGE)