summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@open-infrastructure.net>2023-02-02 13:42:48 +0000
committerDaniel Baumann <daniel.baumann@open-infrastructure.net>2023-02-02 13:42:54 +0000
commit3210f9a20035a241d9c53e93cf99da5d313163eb (patch)
tree5883f9a3ea0fcdb2a53fa96c63f3ed2c46a811d5 /debian/rules
parentReleasing version 20221223. (diff)
downloadcompute-tools-3210f9a20035a241d9c53e93cf99da5d313163eb.tar.xz
compute-tools-3210f9a20035a241d9c53e93cf99da5d313163eb.zip
debian (FIXME)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f2a01c2
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+PACKAGE := open-infrastructure-container-tools
+
+%:
+ dh ${@}
+
+override_dh_auto_build:
+ # disabled
+
+override_dh_auto_install:
+ dh_auto_install -- DESTDIR=$(CURDIR)/debian/$(PACKAGE)
+
+execute_after_dh_auto_install:
+ rm -f debian/$(PACKAGE)/usr/share/doc/*/CHANGELOG.txt
+ rm -f debian/$(PACKAGE)/usr/share/doc/*/LICENSE.txt
+
+ mv debian/$(PACKAGE)/usr/share/doc/* debian/$(PACKAGE)/usr/share/doc/$(PACKAGE)
+
+override_dh_installsystemd:
+ dh_installsystemd --no-restart-after-upgrade --no-start --no-stop-on-upgrade